ErrorZilla Plus Version History

13 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 1.2.4 230.7 kB Works with Firefox 4.0 and later

Fix problem that causes this add-on to stop working on Firefox 34.
Fix misaligned buttons on the error page.

Version 1.2.3 228.4 kB Works with Firefox 4.0 and later

Fix bug that cripples auto retry. (Thanks to Lan Zhen)
Optimize error page layout. (Thanks to Lan Zhen)
Add Swedish translation. (Thanks to Mikael Hiort af Ornäs)

Version 1.2.2 227.3 kB Works with Firefox 4.0 and later

Fix a bug that trim information is not correctly shown.
Unify the appearance of trim information in preference window and error page.
Make the proxy configuration list double-clickable to edit proxy.

Update in 1.2.1:
Execute scripts on the error page in sandbox, which prevents possible dangerous code be executed.

Version 1.2 226.3 kB Works with Firefox 4.0 and later

  • From this version, ErrorZilla Plus no longer patches error page file directly. This may improve compatibility for various platforms and reduce difficulties.
  • Use Firefox preference system instead of local files to store preferences. Instant apply is available now. This should improve user experience, especially for Mac users.
  • Error page background image tweak.

Version 1.1 418.8 kB Works with Firefox 4.0 and later

  • Tools URLs are customizable now.
  • Better preference window UI.
  • Add Japanese translation (thanks to 能美涼子).
  • Bug fix.

Version 1.0 409.6 kB Works with Firefox 4.0 and later

Major update for Firefox 4.0. Due to Firefox new security policy, XUL controls are not allowed to be embedded in HTML. Therefore, you will notice the UI change of proxy list. All functions are retained.

Version 0.8.1 409.6 kB Works with Firefox 3.5 - 3.6.*

This version fixes a bug causing the malfunction of "Proxify" feature. It also verified to be working on the latest Firefox 3.6.

Fix a problem causing glitch in the layout of in tool buttons in some locale versions.

From this version, Firefox versions older than 3.5 are not longer supported.

Version 0.8 409.6 kB Works with Firefox 3.0 - 3.5.*

Major update:

- Add tools-specific options:
1) open tools in new tab or window instead of the current.
2) AutoRetry: automatically try the error URL. Can be activated on all types of errors or only on time-out errors. Retry interval ranges from 1 second to 1 hour.
Preference data are stored in toolsPref.js

- Change the type of the test proxy progress bar to undermined.

- All generated files (netError.xhtml, proxyData.js, toolsPref.js) are placed in a separate "custom" directory, apart from the content directory.

- Many code changes, e.g. aggregate tools URL in a Javascript object.

Version 0.7 407.6 kB Works with Firefox 3.0 - 3.5.*

ErrorZilla Plus is now updated for Firefox 3.5! Below are the major changes in this version:

- Add "Test proxy" function. You can test your proxy configuration in the Add Proxy or Edit Proxy window.
- Fix error of the "Trace" tool.
- Use the new Firefox 3.5 logo as the background in the error page.
- New add-on icon, which is also based on the Firefox 3.5 logo.

Version 0.6.2 387.1 kB Works with Firefox 3.0 - 3.5.*

Move proxy data out of netError.xhtml, and store in an independent file "proxyData.js". Re-patching will not erase proxy data anymore. This change also slightly improves proxy data writing preformance by avoiding touching netError.xhtml.

Please always remember to export and backup your proxy data before updating EZP.

Version 0.6.1 388.1 kB Works with Firefox 3.0 - 3.1b3

I changed the detection of toolkit.jar file to a more general approach so that from this version both Windows and Linux users can use EZP immediately after installation. No manual patch is required anymore.

However, the manual patch and browse buttons are still there. Use them as you want.

Please refer the release note of version 0.6 for more information.

Version 0.6 387.1 kB Works with Firefox 3.0 - 3.0.*

From this version, EZP becomes more extensible to different kinds of web proxies. I changed both underlying proxy infrastructure code and proxy list so that user can choose different type of URL encoding and tricks from one web proxy to another.

Most web proxies use Base64 to encode the destination URL, while some others only do a simple percent-encoding. Many of them also trim the HTTP protocol prefix when encoding (http://www.hostname.com becomes ://www.hostname.com). To adapt their formats, I added encoding algorithm and trim options in this version. I will add more algorithm and trick options in the future if necessary.

Linux users can install EZP now (they cannot use the 0.5.x versions). However, they may need to choose their toolkit.jar file in system manually first, which contains the original error page file netError.xhtml. While in Windows versions, this file is along with the Firefox executable binary, in some Linux distributions, this file could be in a XULRunner directory. Please refer the snapshot to find this file.

Also, user can check the error page patch status in the preference window. A Linux user may notice the status is "not existed". After locating the toolkit.jar and patching correctly, the status will change to "existed and patched". Please restart the preference window after you do patching.

When Firefox encounters an error page with SSL related error (such as ssl_error_bad_cert_domain), the proxies cannot be loaded. This is due to a special procedure in the original error page. However, SSL related error is not a connection error. Web proxies cannot provide any help in such case.

Version 0.4.4 386.0 kB Works with Firefox 3.0 - 3.0.*

- Added column headers on the listbox in the error page.
- Updated pre-defined proxy list.