move to opera Rated 4 out of 5 stars

This was the only plugin holding me back from using the new firefox 10 version (by the end of 2012 we'll probably be on version firefox 300.00!). So to cut a long story short, I installed another browser having found dust me selectors for opera. I don't use dust me selectors as often so I can switch between the two. So if your waiting for an update before diving in to firefox 10 you may want to do what I did.

This review is for a previous version of the add-on (2.2).