Not compatible Rated 1 out of 5 stars

This was a must have extension for me, but it's been nothing but trouble since FF5. I get random javascript errors all the time with this extension. I got sick of having to close them and I disabled it. I hope someone updates this one. Right now, there's no way to classify this as compatible with FF 5 or 6 given the errors.