Great Add-On... Rated 4 out of 5 stars

One of my favorite add-ons, but it's incompatible with FF4.0 Beta 6 version.

This review is for a previous version of the add-on (1.1.10).  This user has a previous review of this add-on.