Does not work in 9.0.1 Rated 1 out of 5 stars

firefox 9.0.1
none of the described security options are checked, yet extension does not work