ok, need newest release for FF 9.* Rated 4 out of 5 stars

light, simple to use, I like it

IMO the only point is the slow to follow FF changes. E.g.: version 1.02.1 was on 3rd Jan 2012 and compatibile with FF 8.* .... but FF was already at 9.0.1...

anyway, thx for this addon :)))

This review is for a previous version of the add-on (1.02.1).