FF3.5 Compatibility Rated 5 out of 5 stars

Surfing with Dotcomplete is substantially superior to my experience after switching to FF3.5. Please make it compatible with the latest FF version