Rated 4 out of 5 stars

Yes, please: an update that works with Firefox 3.5 would be very welcome. Great product!