Rated 5 out of 5 stars

Please update this extension for FF 3.5, I can't live without it!