Upgrade! Rated 5 out of 5 stars

Yeah, I agree with all people! Please upgrade it so we can use it in firefox 3.... please, please, please, please?