worked on Firefox 3.6.4 for me Rated 5 out of 5 stars

I'm on Firefox 3.6.4 and it worked fine for me. Thanks for this much needed add-on. It should be integrated into Firefox in my opinion.

This review is for a previous version of the add-on (1.4).