This works in Firefox 4: here's how: Rated 4 out of 5 stars

Many 'old' addons CAN work in FF 4, except that their configuration file explicitly states that its "maxVersion" (the highest level of compatibility) is less than 4. Something like "3.6*" or "3.*". The instructions below tell you how to extract this file from the .xpi package, edit it in a text editor, and reinsert it into the package. Then you simply hit Ctrl-O to Open a file, then select your newly-modified .xpi file, and that's it.
http://www.neowin.net/forum/topic/685702-guidehow-to-make-firefox-addons-compatible-with-the-newest-release/

I tried it with CuteMenus and it works great! My only advice is that you change the version NOT to 4.0*, but to 4.* (otherwise, if this addon isn't updated before version 4.1 of FF comes out, it will stop working when you upgrade).

If there are other non-updated addons you want to try with this, just remember that some plugins still won't work, because deep down they really are incompatible; but most ARE compatible except for the small technical detail that this fix corrects.