broken Rated 5 out of 5 stars

firefox 12.a2 > broken

This review is for a previous version of the add-on (1.4.1-signed). 

Yeah

Yeah I know. Firefox only lets me specify a max version number of like 2 more than we're on now. If I could I'd specify that my add-on works for firefox version 2.0 - 9999.9 but it won't let me do that. I'll update it long before 12.0 comes out standard.