Compatibility Rated 1 out of 5 stars

The best Theme but unfortunately it is not compatible with FF above v5. -> only 1 star. As soon as it is compatible with the current version of FF -> 5 stars!. Sorry.