unsafe at least up to 2013-06-15 Rated 1 out of 5 stars

Seems nice at the first glance, but be warned this addon had severe security issues in the past!
quote: "If you used group chat in Cryptocat from October 17th, 2011 to June 15th, 2013 assume your messages were compromised. DSA is probably broken in one-to-one chat over OTR. ECDSA is probably broken in group chat. You must update Cryptocat to at least 2.1.12 to be safe from known problems..."

source: http://tobtu.com/decryptocat.php

This review is for a previous version of the add-on (2.1.12).