Rated 5 out of 5 stars

Please add support for Firefox 3.6.3 please. Thank you very much

This review is for a previous version of the add-on (1.6).