Not yet for CT's Rated 1 out of 5 stars

Since the update to FF7 this product is no longer compatible. Go elsewhere for now

This review is for a previous version of the add-on (6.0.1-signed).