Compatibility Rated 3 out of 5 stars

Good addon, but it is not currently compatible with the current version of Firefox, 7.0.1. This shortcoming significantly diminishes its value.

This review is for a previous version of the add-on (0.1.1).