SeaMonkey version wanted Rated 3 out of 5 stars

Since this gadget was written for Firefox 3, it should work for SeaMonkey 2 and later, but it won't install due to the lack of support in the install.rdf file. Disappointing. For a die-hard SeaMonkey all-in-one suite user, a clear cache button would be a very useful thing for Web development.