For everyone who can't wait any longer... Rated 5 out of 5 stars

1) Install the Nightly Tester Tool add-on
https://addons.mozilla.org/en-US/firefox/addon/6543
2) Go to "Tools" > "Add-Ons"
3) Right-click on the desired, incompatible add-on
4) Click "Override compatibility"
5) Add-on will install
6) Be aware that it might be instable or crashes FF.
(Classic Compact has a bug that does not show the Close Tab button on each tab.)
7) ...
8) Profit!

This review is for a previous version of the add-on (3.0.9).