works in 3.5 beta 4 Rated 3 out of 5 stars

I'm running this in firefox 3.5 beta 4 and it works fine after editing the rdf file. See directions at

http://lifedev.net/2006/10/firefox20-extension-update/

use wordpad to change the max version number to “3.5b4″ or whatever version of firefox you are running.

I couldn't get the xpi file to download directly from firefox, so I went to this page, pasted the address into IE, and then was able to download it.

Once having installed it, it is "okay" but I'm not a YouTube junkie. I have not tried substituting the video player, though.