Rated 5 out of 5 stars

I find this extension quite useful. Firefox thinks version 6.0.1 isn't compatible with FF 3.6.21 , although it seems to work OK to me.

This review is for a previous version of the add-on (6.0.1).