Not Compatible with 3.6 Rated 3 out of 5 stars

This looked to be exactly what I needed after the apparent demise of UpDown but unfortunately on install it is reported as Not Compatible with Firefox 3.6 despite the notation that it is compatible with 2.0 - 3.7a1pre.
Download links on the Author's home page mentioned above are dead as well. Would be great to see this updated for the current Firefox version.

This review is for a previous version of the add-on (5.3.2).