3.6? Rated 4 out of 5 stars

It is a very interesting idea but 3.6 users can't even give it a try. A growing number of us are rebelling against the rapid release nightmare and staying with the best browser on the planet- FF3.6


Edit: Thank you for the reply. I will give the other one a look. I do feel that Mozilla has put add-on developers in a tough situation though by releasing the catastrophic 4 and 5 and then not approving updates fast enough. This is why I think that developers should consider backwards compatability.

This review is for a previous version of the add-on (0.7). 

There is already an add-on for Firefox<4.0 that provides the same functionality: https://addons.mozilla.org/en-US/firefox/addon/auto-shutdown/