Rated 5 out of 5 stars

I have updated the Max Version to 5.0 in the .rdf file of the .xpi package and installed on FF5. Seems to work without any further modifications.

This user has other reviews of this add-on.