Rated 5 out of 5 stars

Can confirm that Auto Context works with Firefox 4.0.1 with the install.rdf file in the xpi modified as detailed elsewhere.

This user has other reviews of this add-on.