Rated 4 out of 5 stars

Here's a workaround for those who want this to be installed in FF versions later than 3.6.
1-Download the addon xpi from any other browser.
2-Open archive inside any File unarchivers like 7zip,etc.
3-Locate the file install.rdf
4-rename it to install.txt
5-open it in notepad and find "em:maxVersion>3.0.*</em:maxVersion"
6-Replace 3.0 with 23.0,24.0,etc.
7-Save it
8-Rename it again to install.rdf
9-Close 7zip
10-Drag the xpi file to the firefox window
11-Voila! Installation dialog box is here :)
Hope this works.