Compatibility issue Rated 5 out of 5 stars

Yes, it is NOT compatible with v3.6.23 and it is a hell of a time to find previous version. Developer should keep at least few previous versions on his site and not only 'the latest and greatest'.
Otherwise it is great add-on which simplifies daily browsing. Something Mozilla should buy for big $$$ from developer and make it standard in all their browsers.

This review is for a previous version of the add-on (0.7.14.1-signed).