extension broken with FF 3.5.5 Rated 3 out of 5 stars

broken with Firefox 3.5.5 ... please fix