Aeon Clouds Version History

60 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 2.0.2 1.1 MB Works with Firefox 1.5 - 3.0a1

Version 2.0 1.1 MB Works with Firefox 1.5 - 3.0a1

Version 1.9.5 1.1 MB Works with Firefox 1.5 - 3.0a1

Sweated the tabs down, restored the menus to a non-cramped height and fixed some problems with the search engines.

Version 1.9.4 1.2 MB Works with Firefox 1.5 - 3.0a1

Many bugfixes, many updates to make compatible with current 2.0b2 and 3.0a1 builds.

Version 1.9.3 1.2 MB Works with Firefox 1.5 - 3.0a1

Favicon tweaks for 1.5. Up-to-date code for 2.0b2 - 3.0a1.

Version 1.9.1 1.2 MB Works with Firefox 1.5 - 3.0a1

Fixes the missing mailbox bug.

Version 1.9 1.2 MB Works with Firefox 1.5 - 3.0a1

Version 1.9 fixes the jumping tab bar bug and another obscure bug introduced by 1.8. It also lights up the search engine icon when you hover your mouse over it. This version covers the new tab scroll buttons and the all tabs button with its dropdown menu. It is compatible with Firefox and Minefield, 1.5 to 3.0.

Version 1.8 1.2 MB Works with Firefox 1.5 - 3.0a1

Version 1.8 corrects some last cosmetic issues with Firefox 1.5.
This theme is also compatible with Firefox 2.0 beta 1, and with Minefield 3.0a1.

Version 1.7.6 1.2 MB Works with Firefox 1.5 - 3.0a1

Version 1.7.5 1.2 MB Works with Firefox 1.5 - 3.0a1

Version 1.7.4 1.2 MB Works with Firefox 1.5 - 3.0a1

Version 1.7.2 1.2 MB Works with Firefox 1.5 - 3.0a1

Version 1.7 1.2 MB Works with Firefox 1.5 - 3.0a1

This version was tested on Firefox 1.5.0.3, Bon Echo (Firefox 2.0a2) and Minefield (Firefox 3.0a1). It works with the new Addons manager and the Places function.

Version 1.6 1.2 MB Works with Firefox 1.5 - 2.0

This version is compatible with the experimental "Places" feature of Firefox.

Version 1.5.0.2 1.2 MB Works with Firefox 1.4.1 - 1.5.0.*

Version 1.5.0.1 1.1 MB Works with Firefox 1.4.1 - 1.5.0.*

Version 1.5 1.1 MB Works with Firefox 1.4.1 - 1.5.0.*

To use this version you must have some version of Firefox 1.5. I highly recommend upgrading if you are still running an old version of Firefox.

Version 1.2 1.2 MB Works with Firefox 1.0 - 1.5.0.*

Version 1.1.9 1.2 MB Works with Firefox 1.0 - 1.5.0.*

Version 1.1.8 1.2 MB Works with Firefox 1.0 - 1.4

Version 1.1.7 1.2 MB Works with Firefox 1.0 - 1.0+

Version 1.1.6 1.2 MB Works with Firefox 1.0 - 1.0+

Version 1.1.5 1.3 MB Works with Firefox 1.0 - 1.0+

Version 1.1.3 1.1 MB Works with Firefox 1.0 - 1.0+

Version 1.1 1.2 MB Works with Firefox 1.0 - 1.0+

Version 1.0.1 1.2 MB Works with Firefox 1.0 - 1.0+

Version 1.0 1.1 MB Works with Firefox 1.0 - 1.0+

Version 0.7 1.1 MB Works with Firefox 1.0 - 1.0+

Version 0.7 installs - for toolbar and context menus - icons on all of the Firefox native menu items and first-level menu icons for a number of extensions.

Version 0.6 1.1 MB Works with Firefox 1.0 - 1.0+

The menu items now have icons.

Version 0.5 760.8 kB Works with Firefox 1.0 - 1.0+