Rated 5 out of 5 stars

great addons, it should be installed with the gnome 3 at the beginning. Sadly now its not compatible with Firefox 7.

This review is for a previous version of the add-on (3.1).