Rated 5 out of 5 stars

This extension should be integrated into Firefox, it's a shame that I didn't know it years ago. Minor nit, to see their own (or in fact all) compatibility reports for a given extension users have to figure out its GUID. For that they have to find their own profile with the extensions folder, open all GUID.xpi files in this folder with 7zip or similar, view the RDF in these xpi files to determine which extension GUID actually is, and finally enter the relevant GUID into the compatibility report search form. [Disclaimer, this review is for version 1.1 as required for FF 10esr, anything "better" won't work for me.]

This review is for a previous version of the add-on (2.0). 

v2.0 Not Support ?? Rated 1 out of 5 stars

Why v2.0 Not Support Mobile 4.0 - 11.0a1, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later ??
Tragedy......

This review is for a previous version of the add-on (2.0).  This user has a previous review of this add-on.

FF19 with many addons - Opening the AOM (add-ons manager) freezes the browser for 2 minutes. Rated 1 out of 5 stars

ACR version 2.0 is installed.

Even after I disabled all my 103 addons (except for the ACR addon) the problem continued.
Here's the Firefoxe's Troubleshooting Information:
https://docs.google.com/file/d/0Bw-lUCA-uA1NTEtFeDBCd0VTdE0/edit

It may be caused by the number of addons.
I have another profile with 61 addons. No problems with this profile.
https://docs.google.com/file/d/0Bw-lUCA-uA1NOXBpTUJ0bG0yNGM/edit

BTW - removing the "extensions.sqlite" file from the profile folder didn't help.

This review is for a previous version of the add-on (2.0). 

Thunderbird support Rated 3 out of 5 stars

What about thunderbird? As of v 2.0 the add on is no longer compatible.

This review is for a previous version of the add-on (2.0). 

Nuked under 20.0A1 Rated 2 out of 5 stars

I hope that what I was listing was actually getting used.

Now, it doesn't even work under 20.0A1.

This review is for a previous version of the add-on (2.0). 

Rated 1 out of 5 stars

It makes Add-ons Manager loads slowly, especially when loading user scripts or user styles category. The XUL version was better.

This review is for a previous version of the add-on (2.0). 

Incompatible with SeaMonkey Rated 2 out of 5 stars

Unfortunately, since the 2.0 update, ACR is not compatible with SeaMonkey anymore :(

On a side note, the presence in the add-on bar makes users permanently submit (more or less useless) compatibility reports - even when version compatibility is supplied by the add-on.

This review is for a previous version of the add-on (2.0). 

After the update do 2.0, firefox uses 30% cpu Rated 2 out of 5 stars

After the update i started to see in the Process Explorer the Firefox using 30% of CPU resources.

Then if i removed the icon from the status bar, Firefox will drop do 0%.

This is all when Firefox is idle.

Please correct this.

This review is for a previous version of the add-on (2.0). 

Nice try but... unstick the icon please! Rated 2 out of 5 stars

Pretty please, as others have already said, make that icon's position/visibility configurable. It's very irritating. IMO, the best would be to make it appear inside the normal status bar (or "Status-4-evar" addon), so one may place it wherever he wants with the "Organize Status Bar" addon, or even disable it.

Also, why a "submit all" button only? What if one wishes to submit only a few addons status? I suggest adding a fourth state (V, X, ? and "none", where "none" could be achieved by clicking on an already selected icon -V, X, ?- to deselect it without selecting anything else). Then the "submit all" button could report only addons which have something selected. There could also be a header in the top of the window (V, X, ? - none) in order to set the clicked item to all addons.

This review is for a previous version of the add-on (2.0). 

I will wait or even deaktivate Rated 1 out of 5 stars

Many Tks to everybody having commented v2-update. I will wate updating this add-on, or wil even deaktivate it. I do not need this silly icon. 1 star for v2, 4 stars for v1.1.

This review is for a previous version of the add-on (2.0). 

Rated 1 out of 5 stars

Add-on disabled. Will be activated again when the icon will be configurable.

This review is for a previous version of the add-on (2.0). 

let us remove that icon Rated 1 out of 5 stars

why making an irremovable icon? Do you think we are stupid enough not to know how to use this addon?

This review is for a previous version of the add-on (2.0). 

v2.0 needs a redo Rated 1 out of 5 stars

As other posters have mentioned, v2.0 of this addon puts a non-removable icon in your browser status bar. At least if you have a third-party status bar addon installed; I use "Status-4-Evar" available on this site. It may do so even if you don't have such an addon.

You can "temporarily" get rid of it by opening Toolbars/Customize and dragging the icon to that panel. But on exiting and restart of Firefox, it automatically reappears again. There is no way to change this irritating conduct I've yet found.

This behavior is totally unlike what versions prior to 2.0 did. They did not automatically force an icon on you. No other addon I've tried (and that's been many) behaves this way.

Consequently, Addon Compatibility Reporter v2.0 is uninstalled here and I've recommended locally that all users who dislike this to do the same.

Hopefully future updates will remove this annoying problem.

This review is for a previous version of the add-on (2.0). 

Rated 1 out of 5 stars

Why I can't force enable incompatible addons? Without that this is an useless addon.

This review is for a previous version of the add-on (2.0). 

Rated 1 out of 5 stars

Please god, can we lose the jigsaw thing in the add-on bar. It's incredibly irritating.

Thank you.

This review is for a previous version of the add-on (2.0). 

Rated 1 out of 5 stars

Never ceases to amaze me how people can work so hard to make something that worked just fine....work many times worse.

Ok I'll be the first, so just how do I remove that stupid puzzle looking piece in the lower right hand corner of my Add-On bar???

Have tried dragging and dropping it via the custom box of my tool bar options and it goes away till I close and open the browser again.

So now do I have to revert back to the old version and hack even this too so it doesn't keep reminding me to update?

This review is for a previous version of the add-on (2.0). 

Rated 1 out of 5 stars

New version terrible!!! - it work very slowly, I try to open add-on tab - and I cannot see it in ten minute.
Old version this add-on worked slow, but more faster (one minute).
I install 500 add-ons, with 100 turned on, another turned off.
FF 16.0.2, Xubuntu 12.10-64

This review is for a previous version of the add-on (2.0). 

Rated 5 out of 5 stars

This is a must-have addon, as for users, as for developers. In fact I believe this should be a built-in feature of the browser itself!

The only complaint I have, as developer I get quiet mixed reports with no explanation why addon doesn't work. If we could enforce leaving comment when addon being reported as "not working", it would really help developers.

This review is for a previous version of the add-on (1.1). 

@ kumarakshay Rated 5 out of 5 stars

Thank you for your excellent help howto "upgrade addons" for latest versions of thunderbird.

This review is for a previous version of the add-on (1.1). 

How to install any old addon without this Rated 1 out of 5 stars

Here's a workaround for those who want any addon to be installed in FF versions later than x.xx
1-Download the addon xpi from any other browser.
2-Open archive inside any File unarchivers like 7zip,etc.
3-Locate the file install.rdf
4-rename it to install.txt
5-open it in notepad and find "em:maxVersion>x.x.*</em:maxVersion"
6-Replace x.x with 23.0,24.0,etc.
7-Save it
8-Rename it again to install.rdf
9-Close 7zip
10-Drag the xpi file to the firefox window
11-Voila! Installation dialog box is here :)
Hope this works.
Thanks,
Akshay

This review is for a previous version of the add-on (1.1).