Rated 5 out of 5 stars

I do understand the grumbling of some developers that this add-on doesn't do anything useful because they already know which versions their add-ons work with and they mark the version they are compatible with.

However, while this may be true of some developers, it is certainly not true of all. I have a dozen add-ons that are very useful and work perfectly fine with versions much higher than the ones marked by their developers. This add-on provides a convenient way of forcing compatibility (doing it manually is no rocket science but still this is much more convenient).
While many developers might find this annoying, I am sure some would find it useful, and for users it is most certainly useful.
Overall great add-on!

This review is for a previous version of the add-on (0.7).