Rated 3 out of 5 stars

getting error - not compatible with FF 3.5.3

This review is for a previous version of the add-on (2.98).