Rated 5 out of 5 stars

To those having compatibility difficulties following upgrade to Firefox 3.5, follow Xamar's advice in a previous comment and manually edit saved "aardvark.xpi" file, changing "3.0*" to "3.5*" in the "install.rdf". This tweak will allow installation.

This review is for a previous version of the add-on (2.97).