Rated 1 out of 5 stars

It is not compatible with Thunderbird 24.0.

This review is for a previous version of the add-on (2.10.4).