Thunderbird 24.0 Rated 1 out of 5 stars

It doesn't seem to install with Thunderbird 24.0