Dictionary Switcher Version History

22 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 1.3.3.1-signed.1-signed 24.4 KiB Works with Firefox 2.0 and later, SeaMonkey 1.1 and later, Thunderbird 2.0b2 and later

Got Mozilla to fix their documentation, and now proper code is used to query installed dictionaries. Hopefully no more time will have to be diverted from real development, if we can ever get back to it again...

Version 1.3.2.1-signed.1-signed 24.1 KiB Works with Firefox 2.0 and later, SeaMonkey 1.1 and later, Thunderbird 2.0b2 and later

-Fixes by Ingo van Lil
-Added locales: de-DE, fr, nl, pl

Version 1.3.1.1-signed.1-signed 20.6 KiB Works with Firefox 2.0 and later, SeaMonkey 1.1 and later, Thunderbird 2.0b2 and later

-Merged Switcher 1.0.1 for Fx and 1.1.5 for TB.
-Applied changes by NettiCat; original mod (switcher 1.2nc) linked from Dao's site, in the comments for switcher 1.0.1 for Fx.
-Added support for FireFox 4+ ToolBarPalette.
-Added SeaMonkey 2 support to install.rdf and chrome.manifest.
-Removed "let" keyword requirement, added install.js and contents.rdf files to retain SeaMonkey 1.x compatibility.
-Added a couple of new strings to the locales set (tooltip & initial label). The following localizations need an update and have been temporarily removed:
ca-AD, da, de-DE, fr, hr, hu, it, ko-KR, nl, pl, pt-BR, ru, sk, sv-SE, tr-TR, uk-UA, zh-CN, zh-TW.

Version 1.0.1.1-signed.1-signed 28.6 KiB Works with Firefox 2.0 and later

umlaut handling fixed

Version 1.0 23.0 KiB Works with Firefox 2.0 - 3.6a1pre

support for rich text editors (e.g. Gmail)

Version 0.9 22.0 KiB Works with Firefox 2.0 - 3.1a1pre

* smarter auto-detection based on the host
* default dictionary selection at startup fixed
* added workaround for bug 436717
* added support for Firefox 3.1a1pre

Version 0.8.1 22.0 KiB Works with Firefox 2.0 - 3.0.*

compatible with Firefox 3

Version 0.8 17.0 KiB Works with Firefox 2.0 - 3.0a2

- experimental support for as-you-type detection
- added a list of installed dictionaries to the context menu
- localized: ko-KR

Version 0.7.2 16.0 KiB Works with Firefox 2.0 - 3.0a2

- compatible with Firefox 3.0a2
- localized: ca-AD, tr-TR
- auto-detection enabled by default

Version 0.7.1.3 14.0 KiB Works with Firefox 2.0 - 3.0a1

small fixes

Version 0.7.1.1 14.0 KiB Works with Firefox 2.0 - 3.0a1

- changing the dictionary on a site affects all textareas, if none is focused
- fixed bug where the spellcheck UI would contain duplicated dictionary entries

Version 0.7 14.0 KiB Works with Firefox 2.0 - 3.0a1

- automatically remember the dictionary when it has been changed manually for a site
- don’t turn off auto-detection when the dictionary has been changed manually
- predicate that the language was automatically detected only if it actually succeeded
- label not highlighted but made bold if the dictionary is remembered for the current site

Version 0.6.2 14.0 KiB Works with Firefox 2.0 - 3.0a1

- don’t recheck form field after switching language, if it’s not inside of the active tab
- label highlighted if the dictionary is remembered for the current site

Version 0.6.1 14.0 KiB Works with Firefox 2.0 - 3.0a1

recheck form field after switching language (even if spellchecking UI hasn't been initialized yet)

Version 0.6 14.0 KiB Works with Firefox 2.0 - 3.0a1

- recheck form field after switching language
- localized: hr, hu

Version 0.5.4 13.0 KiB Works with Firefox 2.0 - 3.0a1

localized: da, zh-TW, es-AR, pt-BR

Version 0.5.3 10.0 KiB Works with Firefox 2.0 - 3.0a1

localized: nl

Version 0.5.2 10.0 KiB Works with Firefox 2.0 - 3.0a1

- some small fixes
- localized: sv-SE

Version 0.5.1 9.0 KiB Works with Firefox 2.0 - 3.0a1

localized: de-DE, fr, it, pl, ru, sk, uk-UA, zh-CN

Version 0.4.5 3.0 KiB Works with Firefox 2.0 - 3.0a1

- fixed: initialization fails with blank startup page
- fixed: initialization fails when no dictionary was selected previously
- prevent memory leak

Version 0.4.2 3.0 KiB Works with Firefox 2.0 - 3.0a1

- some minor fixes
- added support for Firefox 3.0a1

Version 0.4.1 3.0 KiB Works with Firefox 2.0b2 - 2.0.0.*