Not working with Firefox 3.6! Rated 4 out of 5 stars

Please update this plugin to work with Firefox 3.6