Will this work on Firefox 3.6 and newer? Rated 5 out of 5 stars

Hello Randy;Will this work on Firefox 3.6 and newer? I don't see anymore updates,Firefox keeps asking to update to 3.6,and I want to keep the Redsox Theme?