Icon of PlugIn-Checker

PlugIn-Checker 10.0 Compatible with Firefox 57+

by Kevin Hartmann

The easiest and simplest way to check for PlugIn-Updates. Never forget to install the newest safe versions.