Modify Headers Version History

29 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 0.7.1.2b 61.4 kB Works with Firefox 4.0 and later

Fix for bug #24610: Toolbar Icon has vertical orientation instead of horizontal
https://www.mozdev.org/bugs/show_bug.cgi?id=24610

Version 0.7.1.1 61.4 kB Works with Firefox 4.0 and later

Fixed bug 24593: Addon toolbar is always displayed when a new window is opened.

Version 0.7.1.0 61.4 kB Works with Firefox 4.0 and later

* Added the Modify Headers icon
* Replaced 'Always On' preference with Start/Stop button
* Minimum Firefox version required: 4.0
* Fixed bug #23854:
* Enhancements #23473, #24112: Icon/menu available in addon toolbar

Version 0.7.0.2 49.2 kB Works with Firefox 3.6 and later, SeaMonkey 2.0 - 2.0.*

  • Fixed defect (#23612): Resizing columns does not work.
  • Fixed defect (#23754): Redirects to http://number/ when moving an item

Version 0.7.0 49.2 kB Works with Firefox 3.6 and later, SeaMonkey 2.0 - 2.0.*

  • Use Drag and Drop to organize headers
  • Move to Top/Bottom buttons replace Move Up/Down
  • Header Name entry field will autocomplete. Includes pre-defined list, with user customizations added.
  • Fixed defect 13485: Adding Cookie-Header is not successful
  • Enhancement 18885: Use Pulldown Menu for Possible Header Values
  • Lots of small code optimizations

Version 0.7.0beta1 49.2 kB Works with Firefox 3.6 and later, SeaMonkey 2.0 - 2.0.*

Added autocomplete for the header name. Many of the common request headers are available by default. The list will also add any custom headers added.

If the autocomplete list does not contain the desired header name, simply type the name you wish to add.

Version 0.6.12 47.1 kB Works with Firefox 3.0 and later, SeaMonkey 2.0 - 2.0.*

Fixed a bug related to JSON support for Firefox 3.0.

Modify Headers 0.6.* is the last version to support Firefox < 3.6. Version 0.7.* will support Firefox 3.6+ only.

Version 0.7.0alpha2 46.1 kB Works with Firefox 3.6 and later, SeaMonkey 2.0 - 2.0.*

Optimized code for managing headers to provide better separation of concerns. Removed lots of code from ModifyHeaders.Service.

Increased minVersion to Firefox 3.6

Version 0.6.11 46.1 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 - 2.0.*

Fixed a bug related to sorting headers.

Version 0.7.0alpha1 46.1 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 - 2.0.*

Sort headers using drag and drop.

Version 0.6.10 46.1 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 - 2.0.*


  • Added support for Seamonkey 2.0.

  • Fixed defect 32612: Cannot resize columns in header window.

  • Modified all XUL files to use entities in preparation for localization.

  • Added icons to make UI more attractive.

Version 0.6.10beta1 48.1 kB Works with Firefox 3.0 and later, SeaMonkey 2.0 - 2.0.*

Added icons to improve UI.

Version 0.6.10alpha3 27.6 kB Works with Firefox 3.0 and later, SeaMonkey 2.0 - 2.0.*

Configured headers are now stored in a file in the Firefox profile directory and not in preferences. This change has been made to enable development of future features.

Version 0.6.10alpha2 26.6 kB Works with Firefox 3.0 and later, SeaMonkey 2.0 - 2.0.*

Removed unnecessary code. Reduced pollution of global namespace.

Version 0.6.10alpha1 73.7 kB Works with Firefox 3.0 and later, SeaMonkey 2.0 - 2.0.*


  • Added support for Seamonkey 2.0.

  • Fixed defect 32612: Cannot resize columns in header window.

  • Modified all XUL files to use entities in preparation for localization.

Version 0.6.9 75.8 kB Works with Firefox 3.5 and later, SeaMonkey 1.0 - 1.0.*

Two problems introduce with version 0.6.8 have been fixed:


  1. Unable to resize the Modify Headers window.

  2. Unable to open Modify Headers in a new tab.

Version 0.6.8 74.8 kB Works with Firefox 3.5 and later, SeaMonkey 1.0 - 1.0.*


  • Added support for Firefox 4.0:

  • Open the configuration window using Firefox -> Web Developer -> Modify Headers (for those platforms that support it).

  • Modify Headers is still available under the tools menu for all platforms.

  • Changed format of Modify Headers configuration window.

  • Improved Export/Import features.

Version 0.6.6 72.7 kB Works with Firefox 1.0 - 3.6.*, SeaMonkey 1.0 - 1.0.*

Version 0.6.6 fixes a regression with the import function. (Bug 20776)

Version 0.6.5 73.7 kB Works with Firefox 1.0 - 3.1b3, SeaMonkey 1.0 - 1.0.*

* Added comment attribute for each header
* Fixed bug 20755 - Menu item should bring window to front

Version 0.6.4 72.7 kB Works with Firefox 1.0 - 3.1b3, SeaMonkey 1.0 - 1.0.*

Fix for bug 18687 (https://www.mozdev.org/bugs/show_bug.cgi?id=18687) to resolve support for Firefox 3.0b3

Version 0.6.3 73.7 kB Works with Firefox 1.0 - 3.0b3, SeaMonkey 1.0 - 1.0.*

Adds support for Firefox 3.0b3. Fixes a minor bug with header importing.

Version 0.6.2 73.7 kB Works with Firefox 1.0 - 2.0.0.*, SeaMonkey 1.0 - 1.0.*

Adds support for Flock up to v 1.0. Changed the user interface to remove the tabs. Configuration window pops up from the bottom and the help is now hosted externally.

Version 0.6.0 73.7 kB Works with Firefox 1.0 - 2.0.0.*, SeaMonkey 1.0 - 1.0.*

Version 0.6.0 adds an function for exporting and importing headers, so that headers may be shared between developers.

There are also several usability improvements.

Version 0.5.4 67.6 kB Works with Firefox 1.0 - 2.0.0.*, SeaMonkey 1.0 - 1.0.*

This defect has been fixed: The Add, Modify, Filter menulist would not change to the correct value when the Edit button is clicked.

Version 0.5.3 66.6 kB Works with Firefox 1.0 - 2.0.0.*, SeaMonkey 1.0 - 1.0.*

The max version has been modified to 2.0.0.*

Version 0.5.2 66.6 kB Works with Firefox 1.0 - 2.0b2, SeaMonkey 1.0 - 1.0.*

Added support for Firefox 2.0b2, Flock, Seamonkey and the Mozilla Suite.

Version 0.5.1 65.5 kB Works with Firefox 1.0 - 1.5.0.*

Bugfix to switch off debug messages.

Version 0.5.0 65.5 kB Works with Firefox 1.0 - 1.5.0.*

- New option to run Modify Headers with the window closed.
- Support for Firefox 1.5.
- More detailed help.

Version 0.3.1 23.6 kB Works with Firefox 1.0 - 1.0+