Luddite UI 0.2.11

by patrickjdempsey

A sabot in the gears of progress. Note: Firefox 28 will be the last compatible version.

This add-on has been preliminarily reviewed by Mozilla. Learn more