Rated 5 out of 5 stars

can you please update this to work with FF 3.5?