Rated 5 out of 5 stars

This is a great plugin that I have been using for months now. Do not upgrade to 2.7 if you have FF version 3.6 still as it doesn't seem to work. The pre-2.7 version still works with the old browser, though.

This review is for a previous version of the add-on (2.7).