essential Rated 4 out of 5 stars

I found this a few days ago when my mouse battery for my tablet ran out. works perfect with google docs pi. please update to 6.0 ga!!! i gotta find a way to downgrade my firefox to 5.0 now...