Rated 5 out of 5 stars

PLEASE UPDATE.

This review is for a previous version of the add-on (2.0.0). 

Rated 5 out of 5 stars

Please update to make it compatible with Firefox 4.0.

This review is for a previous version of the add-on (2.0.0).