Stack Overflow Reputation Version History

8 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 1.7.0 5.3 kB Works with Firefox 38.0a1 and later

[1]Avoided usage of APIs which are deprecated in Firefox latest versions.
[2]Toolbar introduced instead of a panel inside addon bar to enable future enhancements.

Version 1.6.1-signed 197.1 kB Works with Firefox 14.0 and later

Fixed the issue of main module in version 1.5

Version 1.5.1-signed 197.2 kB Works with Firefox 14.0 and later

  • Upgraded to new SDK 1.14

Version 1.4.1-signed 202.3 kB Works with Firefox 14.0 and later

  • Tried to cut the unnecessary calls to Stack Overflow when the user with opted user number already logged-in into it thus saving little internet traffic. If the user with opted user number not logged-in, it will work as usual.
  • Similarly, if different tabs of Stack Overflow are open, and if the reputation in all tabs matches, then only it will not access Stack Overflow. If there is a mismatch, a request will be made to Stack Overflow.
  • In case of not using internet, the reputation will be refreshed every one minute and in case of internet usage, the repution will be updated every 5 minutes vs. previous 15 minutes.
  • If internet is not available when you start firefox, it will try to reconnect in 2 minutes. Previously the user used to click on the addon to reload.

Version 1.3.1-signed.1-signed 193.7 kB Works with Firefox 14.0 and later

1.Retrieved badges information along with reputation information.
2.Made compatible with old versions also.

Version 1.2.1-signed 193.2 kB Works with Firefox 16.0 and later

1.Fixed the bug introduced in 1.1 where the reputation is getting retrieved. However it is not getting displayed.

Version 1.1.1-signed 193.0 kB Works with Firefox 18.0 and later

1.Added auto refresh functionality every 15 minutes.
2.User click also refreshes the reputation.

Version 1.0.1-signed 192.7 kB Works with Firefox 18.0 and later