Rated 1 out of 5 stars

I can't get any of the features to work with ff17. Beyond that, I couldn't find 'Secure Login' anywhere after clicking on the link to the program's support resource. Leaves me wondering if this thing is dead now.

Support and FF17/18

hi Bill,
Please contact us at www.abine.com/support for assistance. We can't fix every issue but it should be compatible with both 17 and 18. Let us know what your specific problems are please.

thanks!