Rated 1 out of 5 stars

Incompatible with Firefox 28. It would be great get this extension working!